Author Rad or hose?  (Read 1107 times)

0 Members and 1 Guest are viewing this topic.

  • Offline Murphy   gb

    • Crosstourer Pro  ‐    204
    • ***
    • Topic Author

    Offline Murphy

    • Crosstourer Pro
    • ***
    • Topic Author
    • Posts: 204
    • Bike: DCT
    • City / Town: Suffolk
    • Country: gb
    Rad or hose?
    on: Feb 02, 2020, 02.00 pm
    Feb 02, 2020, 02.00 pm
    Just got back after a 40 mile ride out, washed the muck off with a hose then restarted the bike to put it in the shed. Just got her in there when there’s a ‘pop’ and steam starts billowing around the screen.
    Sounds like a hose off to me but I guess it could be the rad.
    Anyone else had similar?

  • Offline Banksy

    • Crosstourer Pro  ‐    109
    • ***
      #1

    Offline Banksy

    • Crosstourer Pro
    • ***
    • Posts: 109
    • City / Town: Torbay
    Re: Rad or hose?
    Reply #1 on: Feb 02, 2020, 03.10 pm
    Feb 02, 2020, 03.10 pm
    Washed mine the other day and got the rad wet.. As I dried the bike the water trapped in the rad fins steamed off and when the fan kicked in it drew the water off the rad and into the fan blades making a popping sound... Could it of been this you heard?

  • Offline Murphy   gb

    • Crosstourer Pro  ‐    204
    • ***
    • Topic Author
    • #2

    Offline Murphy

    • Crosstourer Pro
    • ***
    • Topic Author
    • Posts: 204
    • Bike: DCT
    • City / Town: Suffolk
    • Country: gb
    Re: Rad or hose?
    Reply #2 on: Feb 02, 2020, 06.21 pm
    Feb 02, 2020, 06.21 pm
    A really distinct pop, then coolant dripping from the rad too

  • Offline mzflorida

    • Crosstourer Master  ‐    586
    • ****
      #3

    Offline mzflorida

    • Crosstourer Master
    • ****
    • Posts: 586
    • Bike: 2016 VFR1200X,
    • City / Town: Estero
    Re: Rad or hose?
    Reply #3 on: Feb 02, 2020, 07.03 pm
    Feb 02, 2020, 07.03 pm
    ALuminum weld contracted and cracked perhaps? 

  • Offline Murphy   gb

    • Crosstourer Pro  ‐    204
    • ***
    • Topic Author
    • #4

    Offline Murphy

    • Crosstourer Pro
    • ***
    • Topic Author
    • Posts: 204
    • Bike: DCT
    • City / Town: Suffolk
    • Country: gb
    Re: Rad or hose?
    Reply #4 on: Feb 04, 2020, 05.14 pm
    Feb 04, 2020, 05.14 pm
    Update; took the bike back to the dealer who had done the 16k service just a few days ago. Rad fine, hoses fine, pressure fine, no leaks so false alarm. Seems as though when the rad get wet then the bike is run up to operating temp and the fans cut in (98 deg C) the fans pull the water off the rad fins and squirts it onto the exhaust. Hence the steam. Coolant down by 50ml so there may have been a small air bubble too.
    So big up to Lings of Harleston and Ian G, the tech. Didn’t charge me either.

     



    arab-exile