Author Topic: Heated grips problem  (Read 326 times)

0 Members and 1 Guest are viewing this topic.

Offline bampy

  • Crosstourer Pro
  • ***
  • Posts: 370
  • Bike: DCT Highlander
  • City / Town: Cardiff
  • Country: UK
Heated grips problem
on: December 08, 2019, 11:29:57 AM
I haven't used the bike for a few months started it today and the switch for the Honda grips is flashing 3/4 times and repeating after 4/5 seconds. The grips will not heat up. Any ideas?

#1

Offline Murphy

  • Crosstourer Pro
  • ***
  • Posts: 101
  • Bike: DCT
  • City / Town: Suffolk
  • Country: UK
Re: Heated grips problem
Reply #1 on: December 08, 2019, 11:48:33 AM
Based on the evidence, could it be a knackered battery?

#2

Offline Hartley

  • Crosstourer God
  • *****
  • Posts: 2890
  • Bike: Crosstourer
  • City / Town: Northampton
  • Country: England
Re: Heated grips problem
Reply #2 on: December 08, 2019, 01:47:52 PM
I believe the Honda grips are designed to shut down temporarily should the voltage drop. i did on occaision see the light flasing on mine when i had them fitted (Binned them for Oxfords).
Like Murphy said, battery sounds likely.

Based on many threads on the site it does seem the battery on its way out throws up allsorts of faults on the CT.


#3

Offline bampy

  • Crosstourer Pro
  • ***
  • Posts: 370
  • Bike: DCT Highlander
  • City / Town: Cardiff
  • Country: UK
Re: Heated grips problem
Reply #3 on: December 08, 2019, 05:49:15 PM
Thanks for the advice guys I let the bike run for about ten minutes and they started working normally so as was said earlier it must be something to do with the battery charge